Support Tool
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 9 days ago. Dec 06, 2018 - 16:00 EST
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 9 days ago. Dec 06, 2018 - 12:33 EST
This incident affected: Customer Service (Support Tool).