Limited functionality of Support Tools
Incident Report for ionos.com
Resolved
The issue has been resolved. Our apologies for the inconvenience caused.
Posted Apr 12, 2024 - 04:48 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted Apr 12, 2024 - 04:42 EDT
This incident affected: Customer Service (Support Tool).